autumnc
新手上路
新手上路
  • 社区居民
  • 忠实会员
阅读:1186回复:6

编译问题

楼主#
更多 发布于:2019-06-01 09:40
折腾了好久,现在是nodejs build.js l32通过了,但是install copy这一步又卡了
信息如下:
sudo nodejs build.js install copy
gcc -I/home/dm200/yong-master/llib -DCFG_CUSTOM_XML -Wall -g -O2 -fno-strict-aliasing -pipe -I/home/dm200/yong-master/include -I/home/dm200/yong-master/common `pkg-config --cflags gtk+-3.0` -L/home/dm200/yong-master/llib/install -Wl,-rpath,'$ORIGIN' config_ui.o config_main.o translate.o sync.o gz.o session.o aes.o update.o config_gtk.o  -o /yong-config -ll `pkg-config --libs gtk+-3.0`
/usr/bin/ld: sync.o: undefined reference to symbol 'MD5Init@@LIBBSD_0.0'
//lib/arm-linux-gnueabihf/libbsd.so.0: error adding symbols: DSO missing from command line
collect2: error: ld returned 1 exit status
不知道具体是怎么回事,我查了一下,libbsd.so.0是有的。
沙发#
发布于:2019-06-01 14:23
命令错了
node build.js -C install copy
autumnc
新手上路
新手上路
  • 社区居民
  • 忠实会员
板凳#
发布于:2019-06-01 23:48
成功了,非常感谢
地板#
发布于:2022-05-21 17:28
请问这是在编辑bsd版本么?能否分享一下编辑版本?
我在BSD下用linux兼容库运行,在gtk下没问题,但qt下一直搞不定,qt程序用不了小小。
4楼#
发布于:2022-05-22 00:05
laolang_cool:请问这是在编辑bsd版本么?能否分享一下编辑版本?
我在BSD下用linux兼容库运行,在gtk下没问题,但qt下一直搞不定,qt程序用不了小小。
回到原帖
不清楚bsd,理论上针对每个qt版本都需要针对编译一下小小的qt模块
5楼#
发布于:2022-05-23 05:53
深夜回答,注意休息啊。
读万言 感万物 寻一理
6楼#
发布于:2022-05-23 08:50
要不是BSD下的libreoffice依赖QT,我也就没有输入法的烦恼了。QT太特殊,无法评价。
游客

返回顶部